astah*

Japanese | English
Home astah* オンラインマニュアル

プロジェクトファイルの作成と利用

Eメール 印刷

一度に一つのプロジェクト ファイルを編集します。

bullet1 .astaファイル

astah*のプロジェクトファイルです。

bullet1 プロジェクトファイルの新規作成

次の3つの方法で、ファイルを新規作成できます。

  • スタートアップ画面の新規作成ボタンを押下する
  • メニューバーの[ファイ ル]- [プロジェクトの新規作成]ボタンを押下する
  • ツールバーの [プロジェクトを新規に作成する]ボタンを押下する

    bullet1 新規作成時に開くファイル

    新規作成時に開くファイルは、次の3つから選べます。([システムプロパティ]-[プロジェクト]で設定します)

  1. 空のプロジェクトファイル(図やモデルが全く存在しないファイル)
  2. ユーザーがカスタマイズしたファイル「ユーザーテンプレート」

    手順
    (1) 予め[プロジェクトの新規作成]時に開きたいプロジェクトを作成して、次の場所に保存します。
     ユーザーホーム/.astah/professional(uml)/template/project
    (※templateやprojectフォルダが存在しない場合は作成します)
    (2) [ツール] - [システムプロパティ]を開き、左メニューから[プロジェクト]を選択して、下記内容を設定します
          [プロジェクト新規作成時に使用するテンプレート] : [ユーザーテンプレート]を選択
          [テンプレートファイル] : 開くファイル名

  3. astah*が用意したテンプレートファイル:「astah*ビルトインテンプレート」

    設定方法
    [ツール]-[システムプロパティ]を開き、左メニューから[プロジェクト]を選択して、下記内容を設定します
          [プロジェクト新規作成時に使用するテンプレート] : [astah*ビルトインテンプレート]を選択
          [テンプレートファイル] : 開くファイル名 (標準で搭載されたJava6.asta、Java7.asta、java8.asta、C_Sharp.asta、C++.asta)のいずれか一つを入力します。

  4. bullet1 テンプレートファイルからプロジェクトを新規作成する

    次の三つの方法があります。

    • メニューバーの[ファイ ル]-[テンプレートからプロジェクトの新規作成]から、テンプレートとするファイルを選択して作成する。
    • メニューバーの[ファイル]-[テンプレートからプロジェクトの新規作成]から、以前に使用したプロジェクトを選択 して作成する。
    • メニューバーの[ファイ ル]-[テンプレートからプロジェクトの新規作成]から、astah*テンプレートファイル、またはユーザーテンプレートファイルを選択して作成する。

    bullet1 既存のプロジェクトファイルを開く

    次の六つの方法があります。

    • スタートアップ画面の開くボタンから開く。
    • メニューバーの[ファイル]-[プロジェクトを開く]から開く。
    • ツールバーの [既存のプロジェクトを開く]を使って開く。
    • メニューバーの[ファイル]から、以前に作業したプロジェクトを選択して開く。
    • *.astaファイルをデスクトップ上のアイコンにドラッグする。
    • *.astaファイルを、起動中のastah*のウィンドウにドラッグする。

    * astah* think!で作成したマインドマップファイル(.juth)も同じ方法で読込めます。