english japanese german


astah*で実行できる印刷設定や印刷プレビューの手順などを説明します。


印刷する

  1. 印刷したい図を開きます。
  2. [ファイル] - [印刷]を選択するか、[Ctrl/Cmd + P]キーを押します。
TIPS: 図のタブからも印刷できます。
印刷メニューは、ダイアグラムエディタの図のタブにもあります。
print_on_tab


  1. [ファイル] - [まとめて印刷]を選択します。
  2. プロジェクトに含まれる図が一覧で表示されます。印刷したい図にチェックを入れて印刷します。
TIPS: 印刷順序を指定する
選択ダイアログで上に表示される図から順に印刷します。現在は、印刷メニューは、[名前]、[型]、[親]をクリックしてソートできます。
このソートで不十分な場合は、図名の先頭に番号を入れて、[名前]でソートし印刷順序を指定してください。
print_on_tab


プロジェクトに対して印刷設定を行う

プロジェクトに対して、印刷の基本的な設定を行います。
メインメニューから[ファイル]-[印刷設定(プロジェクト)]を選択して開く画面で設定します。
設定内容は、プロジェクトごとに記憶します。

[ページ]

print_setting
設定項目
  1. 用紙サイズ
  2. 印刷の向き
  3. 余白


print_setting
  • ロゴファイル
    ヘッダーやフッターに含めたい画像ファイル(jpg、gif、png形式)をアップロードします。
    表示場所は、[ヘッダーの編集]/[フッターの編集]ボタンを押して指定します。
  • ヘッダー、フッターの編集
    [ヘッダーの編集]/[フッターの編集]ボタンを押して、含めたい情報と位置を設定します。
    print_setting

[図]


print_setting
  • フレームの印刷 - 図にフレームをつけて印刷します。
  • グリッドの印刷 - グリッド線をつけて印刷します。
  • 中央に印刷 - 図を、印刷領域の中央に表示して印刷します。
  • 1ページに印刷 - 図が大きい場合、スケール変換して1ページに収まるように印刷します。
  • 縮尺設定 - 図の縮尺を指定します。
  • ページ設定 - 図の縦と横の枚数を指定します。例えば、縦2、横1とした場合、縦方向を最大2枚、横方向を最大1枚で印刷します。0あるいは空の場合は、図の大きさに合わせて印刷します。

ユースケース記述・CRUD・要求テーブル

ユースケース記述・CRUD・要求テーブルを、複数ページに分割して印刷するかどうかを設定します。
「複数ページに印刷(縦)」にチェックを付ければ複数ページに、チェックがなければ1ページに印刷します。


ユースケース記述の印刷


図の印刷設定

図単位で印刷設定したい場合は、メインメニュー[ファイル]-[印刷設定(図)]から実行します。
設定できる内容は、前述の プロジェクトに対する設定内容と同じです。 プロジェクト単位で設定した印刷設定をそのまま適用する場合は[印刷時、プロジェクトの印刷設定を利用する]チェックボックスをONにして[了解]ボタンを押します。 図の印刷設定



印刷プレビュー

  1. メインメニュー[ファイル] - [印刷プレビュー]を選択します。
    印刷プレビュー
  2. 印刷プレビュー画面が表示されます。
    印刷プレビュー
    • 印刷 - 印刷します
    • 表示サイズ - パーセント(%)で表示サイズを選択します
    • カラム - 印刷が複数ページになる場合に、プレビュー画面に表示するカラム数(列数)を変更できます
    • 印刷設定 - 印刷設定ダイアログを開きます。

印刷に関する細かい設定

印刷に関する詳細設定は、[ツール] - [システムプロパティ]で設定画面を開いて実行します。

print_setting