astah*

Japanese | English
Home astah* オンラインマニュアル

図の画像出力、コマンドラインツール

Eメール 印刷

図を画像ファイルに出力できます。保存する画像ファイル名はデフォルトで図名が使われます。

export image_123
  • 図をPNG、JPEG、EMF、SVG形式で保存
    ダイアグラムエディタに表示されている図をそれぞれの形式で保存します。
  • 図をまとめてPNG、JPEG、EMF、SVG形式で保存
    選択した図を指定したフォルダにそれぞれの形式で保存します。
  • ※Mac OSでは、EMF形式で保存できません。
  • ※astah* communityではEMF、SVG形式で保存できません。

※ ダイアグラムエディタ上に選択状態の図要素がある場合、その図要素のみ出力されます。

bullet1 SVG出力の準備

別途「Batik SVG Toolkit」ライブラリを設定することで、SVG形式で画像を出力できます。6.7以降は

astahに同梱されているので、この準備作業は不要です。

astahを終了した状態で次の手順を実行してください。

  1. Batik SVG Toolkitをダウンロードします。2013/4/5現在の最新バージョンは 1.7で、batik-1.7.zipをご利用ください。
  2. zipファイルを任意のフォルダで展開します。
  3. 展開して出来たファイル群をそのまま astahのインストールフォルダにコピー、または移動します。次のフォルダ階層になるよう、展開したファイルをまとめて配置してください。
    (インストールフォルダ\lib\batik\batik.jarと配備されれば設定完了です)
    C:\Programs and Files/
        | --- astah-professional/
            |---- lib
                |--- batik/
                    |--- batik.jar
                    |--- ......
                    |--- docs/
                    |--- extensions/
                    |--- samples/
                    |--- lib/
                       |--- ......

bullet1 astahモデルをSVGで出力する二つの方法

メニューからのSVG出力

  1. astahで目的の図を開きます。
  2. [ツール]-[図を画像ファイルに出力]-[図をSVG形式で保存]を選択
  3. 出力するファイルを選択します。

コマンドラインツールからのSVG出力 

Windowsの場合 

  1. コマンドプロンプトを実行して、astahのインストールフォルダに移動します。
  2. コマンドプロンプトで、次のようなコマンドを実行します。
    call astah-command.bat -image all -f C:\input\hoge.asta -t svg -o C:\output
    -f の次に読み込む astahのファイルを指定します。
    -o の次にSVGファイルを出力するフォルダを指定します。

Mac / Linuxの場合

  1. ターミナルを実行して、astahのインストールフォルダに移動します。
  2. ターミナルで、次のようなコマンドを実行します。
    ./astah-command.sh -image all -f /Users/$USER_HOME/output/hoge.asta -t svg -o /Users/$USER_HOME/output

コマンドラインツールを使った画像出力

astah*インストールフォルダに含まれるastah-command.batを使用して、コマンドプロンプトから画像出力します。astah-command.batでは「image」のアクションを実行します。
詳しくは、astah*インストールフォルダ配下のastah*コマンドラインツールガイド「CommandRunner.html」をご参照ください。

bullet1 利用条件

コマンドラインツールの実行には、astah*の実行環境が必要です。実行時、大きなサイズのプロジェクトファイルを扱う場合は、JavaVMのメモリ管理オプションを調整してください。
スタックサイズは、astah上部メニュー [ツール]-[システムプロパティ]-[ファイル]-[プロジェクトの書き込み・読み込み時のスタックサイズ]の設定値を使用します。スタックサイズの指定がない場合は、デフォルトで5Mが使用されます。
astah* communityはEMF、SVG形式での出力に対応していません。

 

bullet1 画像ファイルへ出力する

プロジェクトファイルに含まれる図をPNG、EMF、JPEG のいずれかの形式で画像ファイルへ出力するには、「image」のアクションを使います。
画像形式を指定しない場合は PNG形式で出力されます。
Windowsではコマンドプロンプトを開き、MacやLinuxではターミナルを実行して、astahのインストールフォルダへ移動します。

例1) C:\input\hoge.astaファイルのER図をC:\output配下にPNG形式で出力する

call astah-command.bat -image er -f C:\input\hoge.asta -t png -o C:\output

例2) C:\input\hoge.astaファイルの全図をC:\output配下にPNG形式で出力する

call astah-command.bat -image all -f C:\input\hoge.asta -t png -o C:\output

Mac、Linuxでは、astah-command.bat を astah-command.sh に置き換え、出力先の記述を変更して実行してください。

 

bullet1 オプション

-image (画像出力アクション)

all 全ての図
cl クラス図
uc ユースケース図
ucd ユースケース記述
sc ステートマシン図
act アクティビティ図
seq シーケンス図
com コミュニケーション図
cmp コンポーネント図
dep 配置図
cs 合成構造図
fc フローチャート
dfd データフロー図
er ER図
crud CRUD
mm マインドマップ
rqd 要求図
rqt 要求テーブル
tm トレーサビリティマップ
ignore -ref 参照プロジェクトの図を無視する

他のオプション

-dpi, --dpi [image dpi] 出力解像度 - 出力する画像の解像度を指定する。デフォルトは、96(システムプロパティに設定されている値)。
解像度を72にすると、画面に表示されている大きさと同等の画像を出力する。
-f, --file [target file] 出力対象ファイル - 画像出力したい図を含む astahのプロジェクトファイル
-id, --dgm_id [ids for target diagrams] 出力対象ID指定 - 図のID列をスペース区切りで指定。
この場合、出力時に名前空間のフォルダを作成せず、フラットに画像ファイルを出力する。
ファイル名は、図名ではなく、ID名になる。
-o, --output [output] 出力先ベースフォルダ - 画像の出力先フォルダは、指定した「出力先ベースフォルダ」の配下にプロジェクトファイル名で作成される。
-t, --type [image type] 出力画像フォーマット png, jpg, emf, svg PNG, JPEG, 拡張メタファイル, SVG