english japanese

マインドマップを画像として保存する

  1. 画像として保存したいマインドマップを開きます
  2. [ツール] - [画像出力] - [現在の図]から、保存形式を選択します
    図の画像出力
  3. ファイル名を指定して保存します
astah* community版の制限
astah* communityでは、PNG・JPEG形式のみ出力可です。
図の画像出力


複数のマインドマップを画像としてまとめて保存する

  1. [ツール] - [画像出力] - [図をまとめて]から、保存形式を選択します
    図の画像出力
  2. 図一覧が表示されるので、出力対象の図を選択します
    図の画像出力
  3. プロジェクト内と同じファイル構成で、図が保存されます
    図の画像出力

図要素をコピー&ペーストする

  1. 図上でコピーしたいモデルを選択して[コピー]を選択するか、[Ctrl/Cmd + C]を押します
    図の画像出力
  2. 貼り付け先の図上で、[編集] - [貼り付け]か、[Ctrl/Cmd + V]を押します
ご注意! 複製とは異なります
コピーは、図要素のみをコピーします。例えば図上でクラスをコピー&ペーストした場合は、そのクラスを表現する図要素のみが増えます。
コピー
選択したクラスをベースにクラスを新規作成したい場合は、構造ツリーからクラスを複製してください。
複製


モデルを別のastahファイルにコピー&ペーストする   astah community

  1. 図上でコピーしたいモデルを選択して[コピー]を選択するか、[Ctrl/Cmd + C]を押します
    図の画像出力
  2. 別に起動した.astaファイルで図を開き、[編集] - [貼り付け]か、[Ctrl/Cmd + V]を押して貼り付けます
    別インスタンスで開いたastahにモデルをコピー

図を他のアプリに貼り付ける

  1. 図上でコピーしたいモデルを選択して、[クリップボードにコピー]から、形式を選択します
    クリップボードにコピーする
  2. コピーした画像を、他のアプリケーションに貼り付けてご利用ください
    図の貼り付け

Windowsをご利用の場合は
EMFやOOXML形式も選択できます。OOXML形式でコピーした場合は、Microsoft Wordなどに貼り付け後、[グループ解除]することで、Word上でも図を編集できます。
図の画像出力

     

画像出力やコピーに関する詳細設定

[システムプロパティ] - [画像出力]で、画像出力/コピーに関する詳細を設定できます。

画像

コマンドラインから画像出力する

astah*インストールフォルダに含まれるastah-command.batを使用して、コマンドプロンプトから画像を出力できます。

例: C:\input\hoge.astaファイルのER図を、C:\output配下にPNG形式で出力する
call astah-command.bat -image er -f C:\input\hoge.asta -t png -o C:\output
例: C:\input\hoge.astaファイルの全図を、C:\output配下にPNG形式で出力する
call astah-command.bat -image all -f C:\input\hoge.asta -t png -o C:\output

コマンドラインツールの実行には、astah*の実行環境が必要です。大きなサイズのファイルを扱う場合は、JavaVMのメモリ管理オプションを調整してください。
スタックサイズは、[システムプロパティ]-[ファイル]-[プロジェクトの書き込み・読み込み時のスタックサイズ]の設定値を使用します。スタックサイズの指定がない場合は、デフォルトで5Mが使用されます。


Mac / Linuxの場合
  1. ターミナルを実行して、astahのインストールフォルダに移動します
  2. ターミナルで、次のようなコマンドを実行します
./astah-command.sh -image all -f /Users/$USER_HOME/output/hoge.asta
 -t svg -o /Users/$USER_HOME/output

オプション

-image (画像出力アクション)
all 全ての図 com コミュニケーション図 crud CRUD
cl クラス図 cmp コンポーネント図 mm マインドマップ
uc ユースケース図 dep 配置図 rpd 要求図
ucd ユースケース記述 cs 合成構造図 rqt 要求テーブル
sc ステートマシン図 fc フローチャート tm トレーサビリティマップ
act アクティビティ図 dfd データフロー図 ignore -ref 参照プロジェクトの図を無視する
seq シーケンス図 er ER図

他のオプション
-dpi,
--dpi [image dpi]
出力解像度
出力する画像の解像度を指定します。デフォルトは、96(システムプロパティの設定値)です。解像度を72にすると、画面に表示されている大きさと同等の画像を出力します。
-f,
--file [target file]
出力対象ファイル
画像出力したい図を含む.astaファイルを指定します。
-id,
--dgm_id [ids for target diagrams]
出力対象ID
図のID列をスペース区切りで指定します。出力時には名前空間のフォルダを作成せず、フラットに画像ファイルを出力します。ファイル名は、図名ではなく、ID名になります。
-o,
--output [output]
出力先ベースフォルダ
画像の出力先フォルダは、指定する出力先ベースフォルダの配下に、プロジェクトファイル名で作成されます。
-t,
--type [image type]
出力画像フォーマット
画像ファイル形式を、PNG(png), JPEG(jpg), 拡張メタファイル(emf), SVG(svg)のいずれかを指定します。指定しない場合は、.pngで出力します。